Tuesday, October 30, 2012

Re: GWT 2.5 Java 5 runtime(!) compatibility

Still, other then saying that it is so because it has been said so - I still don't see an argument why the gwt-servlet.jar would technically require Java 1.6. 

True, but some day you have to make the cut. Technically they probably have used a Java 1.6 API somewhere thats not available in Java 1.5. So if you compile using target 1.5 you still can't use the library because a Java 1.5 JVM does not provide the needed API. In that case you would get a NoSuchMethodError at runtime.

A good example for this is String.isEmpty() which has been introduced in Java 1.6.

-- J.

You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To view this discussion on the web visit https://groups.google.com/d/msg/google-web-toolkit/-/KHyOElexUH0J.
To post to this group, send email to google-web-toolkit@googlegroups.com.
To unsubscribe from this group, send email to google-web-toolkit+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.

No comments:

Post a Comment