Saturday, July 30, 2011

Re: ERROR: GWT 2.3 + gwt-maps

Hi, i prefer to use a official api v3, because i've a book that
explain very much the new things of this version. For use this annex,
I need to add this .jar in external jars in build path, and wich
inherits, script, or other things I need to add in .xml module ?
Can you explain this steps, that are before the compile time ? Because
use GWT, Google Maps, Eclipse, all this I've a knowledge, but doesn't
compile Gmaps.jar .
I really appreciate your help, and sorry for my bad english.

On 28 jul, 03:24, Bin Wu <b...@bluepoint.net.au> wrote:
> Qual biblioteca você realmente quer usar? O oficial do Google gwt-maps api
> ou a lib do 3o partido a partir dehttp://code.google.com/p/gwt-google-maps-v3/?
>
> A lib do 3o partido apóia GMaps versão 3, mas já foi preterido por um
> ano. Então eu não sei muito sobre ele.
>
> O oficial do Google api parece suportar apenas mapas versão 2. Eu chequei o
> fonte e compilado com GWT2.3, até agora tudo que eu preciso só funciona bem. Eu
> junto em anexo o jar lib com este post. Ver se isso ajuda.
>
> 2011/7/27 André Nunes <an...@ hotmail.com>
>
>
>
>
>
>
>
> > Oi, eu usando GWT 2.3 com gwt-maps.jar, mas eu tenho problemas, não
> > Compilação, mas eu sigo todos os passos que guia.
>
> > Uma parte dos problemas estão listados abaixo:
>
> > [ERROR] Erros em 'jar: file: / C: / eclipse/gwt-maps-1.1.0/gwt-
> > Maps3-0.2a.jar! / Com / google / gwt / maps / cliente / base / LatLng.java '
> > [ERROR] Erro interno do compilador
> > Java.lang.IncompatibleClassChangeError: interface encontrado
> > Com.google.gwt.core.ext.typeinfo.JClassType, mas a classe era esperado
> > Em
>
> > Com.google.gwt.jsio.rebind.JSWrapperGenerator.generate (JSWrapperGenerator.j ava:
> > 276)
> > Em
>
> > Com.google.gwt.core.ext.GeneratorExtWrapper.generate (GeneratorExtWrapper.ja va:
> > 48)
>
> > Alguém pode me ajudar?
>
> > -
> > Você recebeu esta mensagem porque está inscrito para o Google Groups
> > "Google Web Toolkit" grupo.
> > Para postar neste grupo, envie um e-mail para google-web-toolkit@googlegroups.com.
> > Para sair deste grupo, envie um email para
> > Google-web-toolkit + unsubscribe@googlegroups.com.
> > Para mais opções, visite este grupo em
> >http://groups.google.com/group/google-web-toolkit?hl=en.
>
>
>
> gwt-maps.jar
> 995KExibirdownload

--
You received this message because you are subscribed to the Google Groups "Google Web Toolkit" group.
To post to this group, send email to google-web-toolkit@googlegroups.com.
To unsubscribe from this group, send email to google-web-toolkit+unsubscribe@googlegroups.com.
For more options, visit this group at http://groups.google.com/group/google-web-toolkit?hl=en.

1 comment: